What’s Vulnerable › Vulnerabilities
CVE-2024-56332: Next.js Vulnerable to Denial of Service (DoS) with Server Actions
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-03 · updated 2026-06-17
- Weakness: CWE-770
Description
Next.js is a React framework for building full-stack web applications. Starting in version 13.0.0 and prior to versions 13.5.8, 14.2.21, and 15.1.2, Next.js is vulnerable to a Denial of Service (DoS) attack that allows attackers to construct requests that leaves requests to Server Actions hanging until the hosting provider cancels the function execution. This vulnerability can also be used as a Denial of Wallet (DoW) attack when deployed in providers billing by response times. (Note: Next.js server is idle during that time and only keeps the connection open. CPU and memory footprint are low during that time.). Deployments without any protection against long running Server Action invocations are especially vulnerable. Hosting providers like Vercel or Netlify set a default maximum duration on function execution to reduce the risk of excessive billing. This is the same issue as if the incoming HTTP request has an invalid `Content-Length` header or never closes. If the host has no other mitigations to those then this vulnerability is novel. This vulnerability affects only Next.js deployments using Server Actions. The issue was resolved in Next.js 13.5.8, 14.2.21, and 15.1.2. We recommend that users upgrade to a safe version. There are no official workarounds.
Affected products
- Next.js: from 13.0.0 before 13.5.8; from 14.0.0 before 14.2.21; from 15.0.0 before 15.1.2 — fixed in 13.5.8, 14.2.21, 15.1.2
- Npm Next: from 13.0.0 before 13.5.8; from 14.0.0 before 14.2.21; from 15.0.0 before 15.1.2 — fixed in 13.5.8, 14.2.21, 15.1.2
How to fix
Upgrade to a fixed version: Next.js 13.5.8, 14.2.21, 15.1.2; Npm Next 13.5.8, 14.2.21, 15.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56332 or the next vulnerability affects your stack