What’s Vulnerable › Vulnerabilities
CVE-2024-56333: Remote code execution in onyxia-api
- Severity: critical (CVSS 9.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-20 · updated 2026-06-17
- Weakness: CWE-94
Description
Onyxia is a web app that aims at being the glue between multiple open source backend technologies to provide a state of art working environment for data scientists. This critical vulnerability allows authenticated users to remotely execute code within the Onyxia-API, leading to potential consequences such as unauthorized access to other user environments and denial of service attacks. This issue has been patched in api versions 4.2.0, 3.1.1, and 2.8.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- InseeFrLab onyxia: before 2.8.2; from 3.0.0, < 3.1.1; from 4.0.0, < 4.2.0
References
- https://docs.onyxia.sh/vulnerability-disclosure/known-vulnerabilities/vulnerability-20241219
- https://github.com/InseeFrLab/onyxia/security/advisories/GHSA-qmcw-h4f9-j3h3
Get alerted when CVE-2024-56333 or the next vulnerability affects your stack