What’s Vulnerable › Vulnerabilities
CVE-2024-56361: Stored Cross-Site Scripting (XSS) in lgsl v7.0
- Severity: medium (CVSS 5.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-26 · updated 2026-06-17
- Weakness: CWE-79
Description
LGSL (Live Game Server List) provides online status for games. Before 7.0.0, a stored cross-site scripting (XSS) vulnerability was identified in lgsl. The function lgsl_query_40 in lgsl_protocol.php has implemented an HTTP crawler. This function makes a request to the registered game server, and upon crawling the malicious /info endpoint with our payload, will render our javascript on the info page. This information is being displayed via lgsl_details.php. This vulnerability is fixed in 7.0.0.
Affected products
- tltneon lgsl: before 7.0.0
References
- https://github.com/tltneon/lgsl/commit/3fbd3bb581b636f7fd3ea0592c5f8df87d3a2843
- https://github.com/tltneon/lgsl/security/advisories/GHSA-xx95-62h6-h7v3
- https://github.com/tltneon/lgsl/security/advisories/GHSA-xx95-62h6-h7v3
Get alerted when CVE-2024-56361 or the next vulnerability affects your stack