What’s Vulnerable › Vulnerabilities

CVE-2024-56366: PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file

Description

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to unauthorized reflected cross-site scripting in the `Accounting.php` file. Using the `/vendor/phpoffice/phpspreadsheet/samples/Wizards/NumberFormat/Accounting.php` script, an attacker can perform a cross-site scripting attack. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Affected products

How to fix

Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.7, 2.1.6, 2.3.5, 3.7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-56366 or the next vulnerability affects your stack