What’s Vulnerable › Vulnerabilities
CVE-2024-5637: Market Exporter <= 2.0.19 - Missing Authorization to Arbitrary File Deletion
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The Market Exporter plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'remove_files' function in all versions up to, and including, 2.0.19. This makes it possible for authenticated attackers, with Subscriber-level access and above, to use path traversal to delete arbitrary files on the server.
Affected products
- vanyukov Market Exporter: before 2.0.20 — fixed in 2.0.20
How to fix
Upgrade to a fixed version: vanyukov Market Exporter 2.0.20. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/market-exporter/trunk/includes/class-restapi.php#L427
- https://plugins.trac.wordpress.org/changeset/3098360/market-exporter/trunk/includes/class-restapi.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c3ea4bf9-e109-465e-890a-c2923089fb66?source=cve
- https://plugins.trac.wordpress.org/browser/market-exporter/trunk/includes/class-restapi.php#L427
- https://plugins.trac.wordpress.org/changeset/3098360/market-exporter/trunk/includes/class-restapi.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c3ea4bf9-e109-465e-890a-c2923089fb66?source=cve
Get alerted when CVE-2024-5637 or the next vulnerability affects your stack