What’s Vulnerable › Vulnerabilities
CVE-2024-56374
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-770
Description
An issue was discovered in Django 5.1 before 5.1.5, 5.0 before 5.0.11, and 4.2 before 4.2.18. Lack of upper-bound limit enforcement in strings passed when performing IPv6 validation could lead to a potential denial-of-service attack. The undocumented and private functions clean_ipv6_address and is_valid_ipv6_address are vulnerable, as is the django.forms.GenericIPAddressField form field. (The django.db.models.GenericIPAddressField model field is not affected.)
Affected products
- Debian Linux: 11.0
- Django: from 4.2 before 4.2.18; from 5.0 before 5.0.11; from 5.1 before 5.1.5 — fixed in 4.2.18, 5.0.11, 5.1.5
How to fix
Upgrade to a fixed version: Django 4.2.18, 5.0.11, 5.1.5. Check the vendor advisory for mitigations.
References
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/g/django-announce
- https://www.djangoproject.com/weblog/2025/jan/14/security-releases/
- http://www.openwall.com/lists/oss-security/2025/01/14/2
- https://lists.debian.org/debian-lts-announce/2025/01/msg00024.html
Get alerted when CVE-2024-56374 or the next vulnerability affects your stack