What’s Vulnerable › Vulnerabilities

CVE-2024-56408: PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file

Description

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have no sanitization in the `/vendor/phpoffice/phpspreadsheet/samples/Engineering/Convert-Online.php` file, which leads to the possibility of a cross-site scripting attack. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Affected products

How to fix

Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.7, 2.1.6, 2.3.5, 3.7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-56408 or the next vulnerability affects your stack