What’s Vulnerable › Vulnerabilities
CVE-2024-5641: One Click Order Re-Order <= 1.1.9 - Missing Authorization to Authenticated (Subscriber+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-04 · updated 2026-06-17
- Weakness: CWE-862
Description
The One Click Order Re-Order plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'ced_ocor_save_general_setting' function in all versions up to, and including, 1.1.9. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change the plugin settings, including adding stored cross-site scripting.
Affected products
- cedcommerce One Click Order Re-Order: before 1.1.10 — fixed in 1.1.10
How to fix
Upgrade to a fixed version: cedcommerce One Click Order Re-Order 1.1.10. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/one-click-order-reorder/trunk/includes/class-basket-order.php#L489
- https://plugins.trac.wordpress.org/changeset/3110914/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8a297784-96cd-4135-a8f1-e50f3a0d71bd?source=cve
- https://plugins.trac.wordpress.org/browser/one-click-order-reorder/trunk/includes/class-basket-order.php#L489
- https://plugins.trac.wordpress.org/changeset/3110914/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8a297784-96cd-4135-a8f1-e50f3a0d71bd?source=cve
Get alerted when CVE-2024-5641 or the next vulnerability affects your stack