What’s Vulnerable › Vulnerabilities
CVE-2024-56410: PhpSpreadsheet has Cross-Site Scripting (XSS) vulnerability in custom properties
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have a cross-site scripting (XSS) vulnerability in custom properties. The HTML page is generated without clearing custom properties. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.
Affected products
- PHPOffice PhpSpreadsheet: before 1.29.7; from 2.0.0 before 2.1.6; from 2.2.0 before 2.3.5; from 3.3.0 before 3.7.0 — fixed in 1.29.7, 2.1.6, 2.3.5, 3.7.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.7, 2.1.6, 2.3.5, 3.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/commit/45052f88e04c735d56457a8ffcdc40b2635a028e
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-wv23-996v-q229
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-wv23-996v-q229
Get alerted when CVE-2024-56410 or the next vulnerability affects your stack