What’s Vulnerable › Vulnerabilities

CVE-2024-56411: PhpSpreadsheet has Cross-Site Scripting (XSS) vulnerability of the hyperlink base in the HTML page header

Description

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have a cross-site scripting (XSS) vulnerability of the hyperlink base in the HTML page header. The HTML page is formed without sanitizing the hyperlink base. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Affected products

How to fix

Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.7, 2.1.6, 2.3.5, 3.7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-56411 or the next vulnerability affects your stack