What’s Vulnerable › Vulnerabilities

CVE-2024-56412: PhpSpreadsheet vulnerable to bypass of the XSS sanitizer using the javascript protocol and special characters

Description

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to bypass of the cross-site scripting sanitizer using the javascript protocol and special characters. An attacker can use special characters, so that the library processes the javascript protocol with special characters and generates an HTML link. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Affected products

How to fix

Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.7, 2.1.6, 2.3.5, 3.7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-56412 or the next vulnerability affects your stack