What’s Vulnerable › Vulnerabilities
CVE-2024-5645: Envo Extra <= 1.8.23 - Authenticated (Contributor+) Stored Cross-Site Scripting via Button Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Envo Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘button_css_id’ parameter within the Button widget in all versions up to, and including, 1.8.23 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- EnvoThemes Envo Extra: before 1.8.25 — fixed in 1.8.25
How to fix
Upgrade to a fixed version: EnvoThemes Envo Extra 1.8.25. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/envo-extra/tags/1.8.22/lib/elementor/widgets/button/button.php#L676
- https://plugins.trac.wordpress.org/changeset/3098500/
- https://wordpress.org/plugins/envo-extra/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dbe53b09-84c6-4fb6-9a79-1e4987678129?source=cve
- https://plugins.trac.wordpress.org/browser/envo-extra/tags/1.8.22/lib/elementor/widgets/button/button.php#L676
- https://plugins.trac.wordpress.org/changeset/3098500/
- https://wordpress.org/plugins/envo-extra/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dbe53b09-84c6-4fb6-9a79-1e4987678129?source=cve
Get alerted when CVE-2024-5645 or the next vulnerability affects your stack