What’s Vulnerable › Vulnerabilities
CVE-2024-5646: Futurio Extra <= 2.0.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Advanced Text Block Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Futurio Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘header_size’ attribute within the Advanced Text Block widget in all versions up to, and including, 2.0.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- FuturioWP Futurio Extra: before 2.0.6 — fixed in 2.0.6
How to fix
Upgrade to a fixed version: FuturioWP Futurio Extra 2.0.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/futurio-extra/tags/2.0.5/inc/elementor/widgets/advanced-text-block.php#L265
- https://plugins.trac.wordpress.org/changeset/3100491/#file1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cbb3bd9b-ac1f-4488-931f-2ba37576df2d?source=cve
- https://plugins.trac.wordpress.org/browser/futurio-extra/tags/2.0.5/inc/elementor/widgets/advanced-text-block.php#L265
- https://plugins.trac.wordpress.org/changeset/3100491/#file1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cbb3bd9b-ac1f-4488-931f-2ba37576df2d?source=cve
Get alerted when CVE-2024-5646 or the next vulnerability affects your stack