What’s Vulnerable › Vulnerabilities
CVE-2024-56472: IBM Aspera Shares Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-05 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Aspera Shares 1.9.0 through 1.10.0 PL6 is vulnerable to stored cross-site scripting. This vulnerability allows authenticated users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
Affected products
- IBM Aspera Shares: from 1.9.0 before 1.10.0; 1.10.0, 1.10.0-patch_level1, 1.10.0-patch_level2, 1.10.0-patch_level3, 1.10.0-patch_level4, 1.10.0-patch_level5 (+1) — fixed in 1.10.0
How to fix
Upgrade to a fixed version: IBM Aspera Shares 1.10.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56472 or the next vulnerability affects your stack