What’s Vulnerable › Vulnerabilities
CVE-2024-56497
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-78
Description
An improper neutralization of special elements used in an os command ('os command injection') in Fortinet FortiMail versions 7.2.0 through 7.2.4 and 7.0.0 through 7.0.6 and 6.4.0 through 6.4.7, FortiRecorder versions 7.0.0 and 6.4.0 through 6.4.4 allows attacker to execute unauthorized code or commands via the CLI.
Affected products
- Fortinet FortiMail: from 6.4.0 before 6.4.8; from 7.0.0 before 7.0.7; from 7.2.0 before 7.2.5 — fixed in 6.4.8, 7.0.7, 7.2.5
- Fortinet FortiRecorder: from 6.4.0 before 6.4.5; from 7.0.0 before 7.0.2 — fixed in 6.4.5, 7.0.2
How to fix
Upgrade to a fixed version: Fortinet FortiMail 6.4.8, 7.0.7, 7.2.5; Fortinet FortiRecorder 6.4.5, 7.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56497 or the next vulnerability affects your stack