What’s Vulnerable › Vulnerabilities
CVE-2024-56507: Reflected Cross-Site Scripting (XSS) Vulnerability in LinkAce
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
LinkAce is a self-hosted archive to collect links of your favorite websites. Prior to 1.15.6, a reflected cross-site scripting (XSS) vulnerability exists in the LinkAce. This issue occurs in the "URL" field of the "Edit Link" module, where user input is not properly sanitized or encoded before being reflected in the HTML response. This allows attackers to inject and execute arbitrary JavaScript in the context of the victim’s browser, leading to potential session hijacking, data theft, and unauthorized actions. This vulnerability is fixed in 1.15.6.
Affected products
- Kovah LinkAce: before 1.15.6 — fixed in 1.15.6
How to fix
Upgrade to a fixed version: Kovah LinkAce 1.15.6. Check the vendor advisory for mitigations.
References
- https://github.com/Kovah/LinkAce/commit/c7cd6a323a03ccd89c7f905f7d9f2afc265b7b67
- https://github.com/Kovah/LinkAce/security/advisories/GHSA-cjcg-wj4p-pgc5
- https://github.com/Kovah/LinkAce/security/advisories/GHSA-cjcg-wj4p-pgc5
Get alerted when CVE-2024-56507 or the next vulnerability affects your stack