What’s Vulnerable › Vulnerabilities
CVE-2024-56521
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-06-17
- Weakness: CWE-295
Description
An issue was discovered in TCPDF before 6.8.0. If libcurl is used, CURLOPT_SSL_VERIFYHOST and CURLOPT_SSL_VERIFYPEER are set unsafely.
Affected products
- tecnick tcpdf: before 6.8.0 — fixed in 6.8.0
How to fix
Upgrade to a fixed version: tecnick tcpdf 6.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/tecnickcom/TCPDF/commit/aab43ab0a824e956276141a28a24c7c0be20f554
- https://github.com/tecnickcom/TCPDF/compare/6.7.8...6.8.0
- https://tcpdf.org
Get alerted when CVE-2024-56521 or the next vulnerability affects your stack