What’s Vulnerable › Vulnerabilities
CVE-2024-56539: wifi: mwifiex: Fix memcpy() field-spanning write warning in mwifiex_config_scan()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: mwifiex: Fix memcpy() field-spanning write warning in mwifiex_config_scan() Replace one-element array with a flexible-array member in `struct mwifiex_ie_types_wildcard_ssid_params` to fix the following warning on a MT8173 Chromebook (mt8173-elm-hana): [ 356.775250] ------------[ cut here ]------------ [ 356.784543] memcpy: detected field-spanning write (size 6) of single field "wildcard_ssid_tlv->ssid" at drivers/net/wireless/marvell/mwifiex/scan.c:904 (size 1) [ 356.813403] WARNING: CPU: 3 PID: 742 at drivers/net/wireless/marvell/mwifiex/scan.c:904 mwifiex_scan_networks+0x4fc/0xf28 [mwifiex] The "(size 6)" above is exactly the length of the SSID of the network this device was connected to. The source of the warning looks like: ssid_len = user_scan_in->ssid_list[i].ssid_len; [...] memcpy(wildcard_ssid_tlv->ssid, user_scan_in->ssid_list[i].ssid, ssid_len); There is a #define WILDCARD_SSID_TLV_MAX_SIZE that uses sizeof() on this struct, but it already didn't account for the size of the one-element array, so it doesn't need to be changed.
Affected products
- Linux kernel: from 3.0 before 4.19.325; from 4.20 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64 — fixed in 4.19.325, 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11
How to fix
Upgrade to a fixed version: Linux kernel 4.19.325, 5.10.231, 5.15.174, 5.4.287. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1de0ca1d7320a645ba2ee5954f64be08935b002a
- https://git.kernel.org/stable/c/581261b2d6fdb4237b24fa13f5a5f87bf2861f2c
- https://git.kernel.org/stable/c/5fa329c44e1e635da2541eab28b6cdb8464fc8d1
- https://git.kernel.org/stable/c/a09760c513ae0f98c7082a1deace7fb6284ee866
- https://git.kernel.org/stable/c/b466746cfb6be43f9a1457bbee52ade397fb23ea
- https://git.kernel.org/stable/c/c4698ef8c42e02782604bf4f8a489dbf6b0c1365
- https://git.kernel.org/stable/c/d241a139c2e9f8a479f25c75ebd5391e6a448500
- https://git.kernel.org/stable/c/d7774910c5583e61c5fe2571280366624ef48036
- https://git.kernel.org/stable/c/e2de22e4b6213371d9e76f74a10ce817572a8d74
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56539 or the next vulnerability affects your stack