What’s Vulnerable › Vulnerabilities
CVE-2024-5654: CF7 Google Sheets Connector <= 5.0.9 - Missing Authorization to Limited Site Configuration Update
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-862
Description
The CF7 Google Sheets Connector plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'execute_post_data_cg7_free' function in all versions up to, and including, 5.0.9. This makes it possible for unauthenticated attackers to toggle site configuration settings, including WP_DEBUG, WP_DEBUG_LOG, SCRIPT_DEBUG, and SAVEQUERIES.
Affected products
- GSheetConnector CF7 Google Sheets Connector: before 5.0.10 — fixed in 5.0.10
How to fix
Upgrade to a fixed version: GSheetConnector CF7 Google Sheets Connector 5.0.10. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/cf7-google-sheets-connector/trunk/includes/class-gs-service.php#L52
- https://plugins.trac.wordpress.org/changeset/3099184/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c0da4d55-5025-47cf-9f45-377d8943fc94?source=cve
- https://plugins.trac.wordpress.org/browser/cf7-google-sheets-connector/trunk/includes/class-gs-service.php#L52
- https://plugins.trac.wordpress.org/changeset/3099184/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c0da4d55-5025-47cf-9f45-377d8943fc94?source=cve
Get alerted when CVE-2024-5654 or the next vulnerability affects your stack