What’s Vulnerable › Vulnerabilities
CVE-2024-56595: jfs: add a check to prevent array-index-out-of-bounds in dbAdjTree
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: jfs: add a check to prevent array-index-out-of-bounds in dbAdjTree When the value of lp is 0 at the beginning of the for loop, it will become negative in the next assignment and we should bail out.
Affected products
- Linux kernel: before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.66; from 6.7 before 6.12.5 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.12.5, 6.6.66
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/368a533152220b0a6f1142327d96c6b6361f3002
- https://git.kernel.org/stable/c/3b5d21b56c3774bc84eab0a93aaac22a4475e2c4
- https://git.kernel.org/stable/c/491487eeddccc4bb49f2e59d8c8f35bec89c15ca
- https://git.kernel.org/stable/c/8a4311bbde702362fe7412045d06ab6767235dac
- https://git.kernel.org/stable/c/a174706ba4dad895c40b1d2277bade16dfacdcd9
- https://git.kernel.org/stable/c/a3d408870bc19b794646871bc4c3a5daa66f91c5
- https://git.kernel.org/stable/c/b15000bcbecf27e0f7c0f149a409e5b865e28ca2
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56595 or the next vulnerability affects your stack