What’s Vulnerable › Vulnerabilities
CVE-2024-56596: jfs: fix array-index-out-of-bounds in jfs_readdir
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-08-04
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: jfs: fix array-index-out-of-bounds in jfs_readdir The stbl might contain some invalid values. Added a check to return error code in that case.
Affected products
- Linux kernel: before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.66; from 6.7 before 6.12.5 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.12.5, 6.6.66
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/839f102efb168f02dfdd46717b7c6dddb26b015e
- https://git.kernel.org/stable/c/8ff7579554571d92e3deab168f5a7d7b146ed368
- https://git.kernel.org/stable/c/97e693593162eef6851d232f0c8148169ed46a5c
- https://git.kernel.org/stable/c/9efe72eefd4c4a7ce63b3e4d667d766d2b360cb4
- https://git.kernel.org/stable/c/b62f41aeec9d250144c53875b507c1d45ae8c8fc
- https://git.kernel.org/stable/c/e7d376f94f72b020f84e77278b150ec1cc27502c
- https://git.kernel.org/stable/c/ff9fc48fab0e1ea0d423c23c99b91bba178f0b05
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56596 or the next vulnerability affects your stack