What’s Vulnerable › Vulnerabilities
CVE-2024-56598: jfs: array-index-out-of-bounds fix in dtReadFirst
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-08-04
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: jfs: array-index-out-of-bounds fix in dtReadFirst The value of stbl can be sometimes out of bounds due to a bad filesystem. Added a check with appopriate return of error code in that case.
Affected products
- Linux kernel: before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.66; from 6.7 before 6.12.5 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.12.5, 6.6.66
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/22dcbf7661c6ffc3247978c254dc40b833a0d429
- https://git.kernel.org/stable/c/25f1e673ef61d6bf9a6022e27936785896d74948
- https://git.kernel.org/stable/c/2eea5fda5556ef03defebf07b0a12fcd2c5210f4
- https://git.kernel.org/stable/c/823d573f5450ca6be80b36f54d1902ac7cd23fb9
- https://git.kernel.org/stable/c/8c97a4d5463a1c972ef576ac499ea9b05f956097
- https://git.kernel.org/stable/c/ca84a2c9be482836b86d780244f0357e5a778c46
- https://git.kernel.org/stable/c/fd993b2180b4c373af8b99aa28d4dcda5c2a8f10
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56598 or the next vulnerability affects your stack