What’s Vulnerable › Vulnerabilities
CVE-2024-56616: drm/dp_mst: Fix MST sideband message body length check
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: drm/dp_mst: Fix MST sideband message body length check Fix the MST sideband message body length check, which must be at least 1 byte accounting for the message body CRC (aka message data CRC) at the end of the message. This fixes a case where an MST branch device returns a header with a correct header CRC (indicating a correctly received body length), with the body length being incorrectly set to 0. This will later lead to a memory corruption in drm_dp_sideband_append_payload() and the following errors in dmesg: UBSAN: array-index-out-of-bounds in drivers/gpu/drm/display/drm_dp_mst_topology.c:786:25 index -1 is out of range for type 'u8 [48]' Call Trace: drm_dp_sideband_append_payload+0x33d/0x350 [drm_display_helper] drm_dp_get_one_sb_msg+0x3ce/0x5f0 [drm_display_helper] drm_dp_mst_hpd_irq_handle_event+0xc8/0x1580 [drm_display_helper] memcpy: detected field-spanning write (size 18446744073709551615) of single field "&msg->msg[msg->curlen]" at drivers/gpu/drm/display/drm_dp_mst_topology.c:791 (size 256) Call Trace: drm_dp_sideband_append_payload+0x324/0x350 [drm_display_helper] drm_dp_get_one_sb_msg+0x3ce/0x5f0 [drm_display_helper] drm_dp_mst_hpd_irq_handle_event+0xc8/0x1580 [drm_display_helper]
Affected products
- Linux kernel: before 5.10.233; from 5.11 before 5.15.176; from 5.16 before 6.1.120; from 6.2 before 6.6.66; from 6.7 before 6.12.5; 6.13-rc1 — fixed in 5.10.233, 5.15.176, 6.1.120, 6.12.5, 6.6.66
How to fix
Upgrade to a fixed version: Linux kernel 5.10.233, 5.15.176, 6.1.120, 6.12.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/109f91d8b9335b0f3714ef9920eae5a8b21d56af
- https://git.kernel.org/stable/c/1fc1f32c4a3421b9d803f18ec3ef49db2fb5d5ef
- https://git.kernel.org/stable/c/70e7166612f4e6da8d7d0305c47c465d88d037e5
- https://git.kernel.org/stable/c/780fa184d4dc38ad6c4fded345ab8f9be7a63e96
- https://git.kernel.org/stable/c/bd2fccac61b40eaf08d9546acc9fef958bfe4763
- https://git.kernel.org/stable/c/c58947a8d4a500902597ee1dbadf0518d7ff8801
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56616 or the next vulnerability affects your stack