What’s Vulnerable › Vulnerabilities
CVE-2024-56625: can: dev: can_set_termination(): allow sleeping GPIOs
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: can: dev: can_set_termination(): allow sleeping GPIOs In commit 6e86a1543c37 ("can: dev: provide optional GPIO based termination support") GPIO based termination support was added. For no particular reason that patch uses gpiod_set_value() to set the GPIO. This leads to the following warning, if the systems uses a sleeping GPIO, i.e. behind an I2C port expander: | WARNING: CPU: 0 PID: 379 at /drivers/gpio/gpiolib.c:3496 gpiod_set_value+0x50/0x6c | CPU: 0 UID: 0 PID: 379 Comm: ip Not tainted 6.11.0-20241016-1 #1 823affae360cc91126e4d316d7a614a8bf86236c Replace gpiod_set_value() by gpiod_set_value_cansleep() to allow the use of sleeping GPIOs.
Affected products
- Linux kernel: from 5.15 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.66; from 6.7 before 6.12.5; 6.13-rc1 — fixed in 5.15.174, 6.1.120, 6.12.5, 6.6.66
How to fix
Upgrade to a fixed version: Linux kernel 5.15.174, 6.1.120, 6.12.5, 6.6.66. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1ac442f25c19953d2f33b92549628b0aeac83db6
- https://git.kernel.org/stable/c/3b0c5bb437d31a9864f633b85cbc42d2f6c51c96
- https://git.kernel.org/stable/c/46637a608fb1ee871a0ad8bf70d917d5d95ac251
- https://git.kernel.org/stable/c/ee1dfbdd8b4b6de85e96ae2059dc9c1bdb6b49b5
- https://git.kernel.org/stable/c/faa0a1975a6fbce30616775216606eb8d6388ea1
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
Get alerted when CVE-2024-56625 or the next vulnerability affects your stack