What’s Vulnerable › Vulnerabilities
CVE-2024-56627: ksmbd: fix Out-of-Bounds Read in ksmbd_vfs_stream_read
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-08-04
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix Out-of-Bounds Read in ksmbd_vfs_stream_read An offset from client could be a negative value, It could lead to an out-of-bounds read from the stream_buf. Note that this issue is coming when setting 'vfs objects = streams_xattr parameter' in ksmbd.conf.
Affected products
- Linux kernel: from 5.15 before 5.15.176; from 5.16 before 6.1.120; from 6.2 before 6.6.66; from 6.7 before 6.12.5; 6.13-rc1 — fixed in 5.15.176, 6.1.120, 6.12.5, 6.6.66
How to fix
Upgrade to a fixed version: Linux kernel 5.15.176, 6.1.120, 6.12.5, 6.6.66. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/27de4295522e9a33e4a3fc72f7b8193df9eebe41
- https://git.kernel.org/stable/c/6bd1bf0e8c42f10a9a9679a4c103a9032d30594d
- https://git.kernel.org/stable/c/81eed631935f2c52cdaf6691c6d48e0b06e8ad73
- https://git.kernel.org/stable/c/de4d790dcf53be41736239d7ee63849a16ff5d10
- https://git.kernel.org/stable/c/fc342cf86e2dc4d2edb0fc2ff5e28b6c7845adb9
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
Get alerted when CVE-2024-56627 or the next vulnerability affects your stack