What’s Vulnerable › Vulnerabilities
CVE-2024-5665: Login/Signup Popup ( Inline Form + Woocommerce ) 2.7.1 - 2.7.2 - Missing Authorization to Arbitrary Options Exposure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-862
Description
The Login/Signup Popup ( Inline Form + Woocommerce ) plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the ‘export_settings’ function in versions 2.7.1 to 2.7.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read arbitrary options on affected sites.
Affected products
- xootix Login & Register Customizer – Popup | Slider | Inline | WooCommerce: from 2.7.1 before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: xootix Login & Register Customizer – Popup | Slider | Inline | WooCommerce 2.7.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/easy-login-woocommerce/trunk/includes/xoo-framework/admin/class-xoo-admin-settings.php?rev=3084943#L69
- https://plugins.trac.wordpress.org/changeset/3093994/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1a304e9a-9518-4a6a-b36a-963cb329f5c3?source=cve
- https://plugins.trac.wordpress.org/browser/easy-login-woocommerce/trunk/includes/xoo-framework/admin/class-xoo-admin-settings.php?rev=3084943#L69
- https://plugins.trac.wordpress.org/changeset/3093994/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1a304e9a-9518-4a6a-b36a-963cb329f5c3?source=cve
Get alerted when CVE-2024-5665 or the next vulnerability affects your stack