What’s Vulnerable › Vulnerabilities
CVE-2024-5668: Lightbox & Modal Popup WordPress Plugin – FooBox <= 2.7.28 - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via HTML Data Attributes
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Lightbox & Modal Popup WordPress Plugin – FooBox plugin for WordPress is vulnerable to DOM-based Stored Cross-Site Scripting via HTML data attributes in all versions up to, and including, 2.7.28 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Themergency Foobox: before 2.7.32 — fixed in 2.7.32
How to fix
Upgrade to a fixed version: Themergency Foobox 2.7.32. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3130678/foobox-image-lightbox
- https://www.wordfence.com/threat-intel/vulnerabilities/id/923f9e66-2e26-4ec2-a4b3-439881a6ca10?source=cve
Get alerted when CVE-2024-5668 or the next vulnerability affects your stack