What’s Vulnerable › Vulnerabilities
CVE-2024-56691: mfd: intel_soc_pmic_bxtwc: Use IRQ domain for USB Type-C device
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-28 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: mfd: intel_soc_pmic_bxtwc: Use IRQ domain for USB Type-C device While design wise the idea of converting the driver to use the hierarchy of the IRQ chips is correct, the implementation has (inherited) flaws. This was unveiled when platform_get_irq() had started WARN() on IRQ 0 that is supposed to be a Linux IRQ number (also known as vIRQ). Rework the driver to respect IRQ domain when creating each MFD device separately, as the domain is not the same for all of them.
Affected products
- Linux kernel: from 4.9 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11, 6.12.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0997e77c51330c2866a4f39480e762cca92ad953
- https://git.kernel.org/stable/c/0b648968bfa4f5c9c4983bca9f2de17626ed6fb6
- https://git.kernel.org/stable/c/23230ac3c5ca3f154b64849d1cf50583b4e6b98c
- https://git.kernel.org/stable/c/518e414d24e7037d6cc7198e942bf47fe6f5e8e1
- https://git.kernel.org/stable/c/686fb77712a4bc94b76a0c5ae74c60118b7a0d79
- https://git.kernel.org/stable/c/87a07a5b0b296e489c606ca95ffc16c18821975b
- https://git.kernel.org/stable/c/c310e6916c0b297011d0fec03f168a6b24e9e984
- https://git.kernel.org/stable/c/e1ef62e8d262e3f27446d26742208c1c81e9ee18
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56691 or the next vulnerability affects your stack