What’s Vulnerable › Vulnerabilities
CVE-2024-56707: octeontx2-pf: handle otx2_mbox_get_rsp errors in otx2_dmac_flt.c
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-28 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: octeontx2-pf: handle otx2_mbox_get_rsp errors in otx2_dmac_flt.c Add error pointer checks after calling otx2_mbox_get_rsp().
Affected products
- Linux kernel: from 5.14.1 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11; from 6.12 before 6.12.2; 5.14, 5.14-rc2, 5.14-rc3, 5.14-rc4, 5.14-rc5, 5.14-rc6 (+1) — fixed in 6.1.120, 6.11.11, 6.12.2, 6.6.64
How to fix
Upgrade to a fixed version: Linux kernel 6.1.120, 6.11.11, 6.12.2, 6.6.64. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1611b1ea7cf8d07dff091a45389b10401bb6d5b3
- https://git.kernel.org/stable/c/20e06a5137a1174214bae3a29ce623e69455ee0f
- https://git.kernel.org/stable/c/3ccbc7a518868eff1d5a198b9e454e182b651e00
- https://git.kernel.org/stable/c/f5b942e6c54b13246ee49d42dcfb71b7f29e3c64
- https://git.kernel.org/stable/c/fc595472fbad96533ccbb7b9ebb82b743ec26829
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
Get alerted when CVE-2024-56707 or the next vulnerability affects your stack