What’s Vulnerable › Vulnerabilities
CVE-2024-56716: netdevsim: prevent bad user input in nsim_dev_health_break_write()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-29 · updated 2026-06-17
- Weakness: CWE-1284
Description
In the Linux kernel, the following vulnerability has been resolved: netdevsim: prevent bad user input in nsim_dev_health_break_write() If either a zero count or a large one is provided, kernel can crash.
Affected products
- Linux kernel: from 5.5 before 5.10.233; from 5.11 before 5.15.176; from 5.16 before 6.1.122; from 6.2 before 6.6.68; from 6.7 before 6.12.7; 6.13-rc1, 6.13-rc2, 6.13-rc3 — fixed in 5.10.233, 5.15.176, 6.1.122, 6.12.7, 6.6.68
How to fix
Upgrade to a fixed version: Linux kernel 5.10.233, 5.15.176, 6.1.122, 6.12.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/470c5ecbac2f19b1cdee2a6ce8d5650c3295c94b
- https://git.kernel.org/stable/c/81bdfcd6e6a998e219c9dd49ec7291c2e0594bbc
- https://git.kernel.org/stable/c/8e9ef6bdf71bf25f4735e0230ce1919de8985835
- https://git.kernel.org/stable/c/b3a6daaf7cfb2de37b89fd7a5a2ad4ea9aa3e181
- https://git.kernel.org/stable/c/d10321be26ff9e9e912697e9e8448099654ff561
- https://git.kernel.org/stable/c/ee76746387f6233bdfa93d7406990f923641568f
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56716 or the next vulnerability affects your stack