What’s Vulnerable › Vulnerabilities
CVE-2024-56727: octeontx2-pf: handle otx2_mbox_get_rsp errors in otx2_flows.c
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-29 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: octeontx2-pf: handle otx2_mbox_get_rsp errors in otx2_flows.c Adding error pointer check after calling otx2_mbox_get_rsp().
Affected products
- Linux kernel: from 5.11 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11; from 6.12 before 6.12.2 — fixed in 6.1.120, 6.11.11, 6.12.2, 6.6.64
How to fix
Upgrade to a fixed version: Linux kernel 6.1.120, 6.11.11, 6.12.2, 6.6.64. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/8c9f8b35dc3d4ad8053a72bc0c5a7843591f6b75
- https://git.kernel.org/stable/c/a479b3d7586e6f77f8337bbcac980eaf2d0a4029
- https://git.kernel.org/stable/c/bd3110bc102ab6292656b8118be819faa0de8dd0
- https://git.kernel.org/stable/c/c4eae7bac880edd88aaed6a8ec2997fa85e259c7
- https://git.kernel.org/stable/c/e3c4e78d636e6dbd8ed72e41b311de2bb7e0b699
- https://git.kernel.org/stable/c/e5e60f17d2462ef5c13db4d1a54eef5778fd2295
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
Get alerted when CVE-2024-56727 or the next vulnerability affects your stack