What’s Vulnerable › Vulnerabilities
CVE-2024-56728: octeontx2-pf: handle otx2_mbox_get_rsp errors in otx2_ethtool.c
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-29 · updated 2026-06-17
- Weakness: CWE-754
Description
In the Linux kernel, the following vulnerability has been resolved: octeontx2-pf: handle otx2_mbox_get_rsp errors in otx2_ethtool.c Add error pointer check after calling otx2_mbox_get_rsp().
Affected products
- Linux kernel: from 5.7 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11; from 6.12 before 6.12.2 — fixed in 5.10.231, 5.15.174, 6.1.120, 6.11.11, 6.12.2, 6.6.64
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 6.1.120, 6.11.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/05a6ce174c0c724e5914e1e5efd826bab8f382b4
- https://git.kernel.org/stable/c/2db2194727b1f49a5096c1c3981adef1b7638733
- https://git.kernel.org/stable/c/55c41b97001a09bb490ffa2e667e251d75d15ab1
- https://git.kernel.org/stable/c/5ff9de1f2712cbca53da2e37d831eea7ffcb43b6
- https://git.kernel.org/stable/c/6cda142cee032b8fe65ee11f78721721c3988feb
- https://git.kernel.org/stable/c/c0f64fd73b60aee85f88c270c9d714ead27a7b7a
- https://git.kernel.org/stable/c/e26f8eac6bb20b20fdb8f7dc695711ebce4c7c5c
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56728 or the next vulnerability affects your stack