What’s Vulnerable › Vulnerabilities
CVE-2024-56736: Apache HertzBeat: Server-Side Request Forgery (SSRF) in Api Config Oss
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache HertzBeat. This issue affects Apache HertzBeat (incubating): before 1.7.0. Users are recommended to upgrade to version 1.7.0, which fixes the issue.
Affected products
- dromara hertzbeat: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: dromara hertzbeat 1.7.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/kdzg36h9yxp0q0n4lhcfppxntjy8rj1x
- https://lists.apache.org/thread/lwfhsllos1rx9v8k0yhl252cbpqpn0sv
- http://www.openwall.com/lists/oss-security/2025/04/16/1
Get alerted when CVE-2024-56736 or the next vulnerability affects your stack