What’s Vulnerable › Vulnerabilities
CVE-2024-5674: Newsletter - API v1 and v2 addon for Newsletter <= 2.4.5 - Missing Authorization to Email Subscribers Management
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-12 · updated 2026-06-17
- Weakness: CWE-862
Description
The Newsletter - API v1 and v2 addon plugin for WordPress is vulnerable to unauthorized subscribers management due to PHP type juggling issue on the check_api_key function in all versions up to, and including, 2.4.5. This makes it possible for unauthenticated attackers to list, create or delete newsletter subscribers. This issue affects only sites running the PHP version below 8.0
Affected products
- The Newsletter Team Newsletter - API v1 and v2 addon for Newsletter: before 2.4.6 — fixed in 2.4.6
How to fix
Upgrade to a fixed version: The Newsletter Team Newsletter - API v1 and v2 addon for Newsletter 2.4.6. Check the vendor advisory for mitigations.
References
- https://www.thenewsletterplugin.com/documentation/developers/newsletter-api-2/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ecd9800e-ce0f-45f3-bb66-3690c51d885b?source=cve
- https://www.thenewsletterplugin.com/documentation/developers/newsletter-api-2/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ecd9800e-ce0f-45f3-bb66-3690c51d885b?source=cve
Get alerted when CVE-2024-5674 or the next vulnerability affects your stack