What’s Vulnerable › Vulnerabilities
CVE-2024-56747: scsi: qedi: Fix a possible memory leak in qedi_alloc_and_init_sb()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-29 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: qedi: Fix a possible memory leak in qedi_alloc_and_init_sb() Hook "qedi_ops->common->sb_init = qed_sb_init" does not release the DMA memory sb_virt when it fails. Add dma_free_coherent() to free it. This is the same way as qedr_alloc_mem_sb() and qede_alloc_mem_sb().
Affected products
- Linux kernel: from 4.10 before 4.19.325; from 4.20 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64 — fixed in 4.19.325, 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11
How to fix
Upgrade to a fixed version: Linux kernel 4.19.325, 5.10.231, 5.15.174, 5.4.287. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/10a6fc486ac40a410f0fb84cc15161238eccd20a
- https://git.kernel.org/stable/c/20b775cf274cfbfa3da871a1108877e17b8b19e1
- https://git.kernel.org/stable/c/4e48e5b26b3edc0e1dd329201ffc924a7a1f9337
- https://git.kernel.org/stable/c/95bbdca4999bc59a72ebab01663d421d6ce5775d
- https://git.kernel.org/stable/c/a4d2011cbe039b25024831427b60ab91ee247066
- https://git.kernel.org/stable/c/b778b5240485106abf665eb509cc01779ed0cb00
- https://git.kernel.org/stable/c/bb8b45883eb072adba297922b67d1467082ac880
- https://git.kernel.org/stable/c/cfc76acaf2c4b43d1e140f1e4cbde15adb540bc5
- https://git.kernel.org/stable/c/eaf92fad1f21be63427920c12f22227e5f757424
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56747 or the next vulnerability affects your stack