What’s Vulnerable › Vulnerabilities
CVE-2024-56754: crypto: caam - Fix the pointer passed to caam_qi_shutdown()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-29 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: caam - Fix the pointer passed to caam_qi_shutdown() The type of the last parameter given to devm_add_action_or_reset() is "struct caam_drv_private *", but in caam_qi_shutdown(), it is casted to "struct device *". Pass the correct parameter to devm_add_action_or_reset() so that the resources are released as expected.
Affected products
- Linux kernel: from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11; from 6.12 before 6.12.2 — fixed in 5.10.231, 5.15.174, 6.1.120, 6.11.11, 6.12.2, 6.6.64
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 6.1.120, 6.11.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1f8e2f597b918ca5827a5c6d00b819d064264d1c
- https://git.kernel.org/stable/c/6187727e57aec122c8a99c464c74578c810cbe40
- https://git.kernel.org/stable/c/66eddb8dcb61065c53098510165f14b54232bcc2
- https://git.kernel.org/stable/c/84a185aea7b83f620699de0ea36907d588d89cf6
- https://git.kernel.org/stable/c/ad39df0898d3f469776c19d99229be055cc2dcea
- https://git.kernel.org/stable/c/ad980b04f51f7fb503530bd1cb328ba5e75a250e
- https://git.kernel.org/stable/c/cc386170b3312fd7b5bc4a69a9f52d7f50814526
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56754 or the next vulnerability affects your stack