What’s Vulnerable › Vulnerabilities
CVE-2024-56756: nvme-pci: fix freeing of the HMB descriptor table
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-29 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: nvme-pci: fix freeing of the HMB descriptor table The HMB descriptor table is sized to the maximum number of descriptors that could be used for a given device, but __nvme_alloc_host_mem could break out of the loop earlier on memory allocation failure and end up using less descriptors than planned for, which leads to an incorrect size passed to dma_free_coherent. In practice this was not showing up because the number of descriptors tends to be low and the dma coherent allocator always allocates and frees at least a page.
Affected products
- Linux kernel: from 4.13 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11, 6.12.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3c2fb1ca8086eb139b2a551358137525ae8e0d7a
- https://git.kernel.org/stable/c/452f9ddd12bebc04cef741e8ba3806bf0e1fd015
- https://git.kernel.org/stable/c/582d9ed999b004fb1d415ecbfa86d4d8df455269
- https://git.kernel.org/stable/c/6d0f599db73b099aa724a12736369c4d4d92849d
- https://git.kernel.org/stable/c/869cf50b9c9d1059f5223f79ef68fc0bc6210095
- https://git.kernel.org/stable/c/ac22240540e0c5230d8c4138e3778420b712716a
- https://git.kernel.org/stable/c/cee3bff51a35cab1c5d842d409a7b11caefe2386
- https://git.kernel.org/stable/c/fb96d5cfa97a7363245b3dd523f475b04296d87b
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-56756 or the next vulnerability affects your stack