What’s Vulnerable › Vulnerabilities
CVE-2024-56802: Tapir allows DeployKey exposure
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-31 · updated 2026-06-17
- Weakness: CWE-285
Description
Tapir is a private Terraform registry. Tapir versions 0.9.0 and 0.9.1 are facing a critical issue with scope-able Deploykeys where attackers can guess the key to get write access to the registry. User must upgrade to 0.9.2.
Affected products
- PacoVK tapir: from 0.9.0, < 0.9.2
References
- https://github.com/PacoVK/tapir/commit/c36360b611fa0ba4f5e250fa43ecf8a294785a03
- https://github.com/PacoVK/tapir/security/advisories/GHSA-rj9m-qf65-f5gg
Get alerted when CVE-2024-56802 or the next vulnerability affects your stack