What’s Vulnerable › Vulnerabilities
CVE-2024-5685: Broken Function Level Authorization (BFLA) in snipe/snipe-it
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-14 · updated 2026-06-17
- Weakness: CWE-862
Description
Users with "User:edit" and "Self:api" permissions can promote or demote themselves or other users by performing changes to the group's memberships via API call.This issue affects snipe-it: from v4.6.17 through v6.4.1.
Affected products
- grokability snipe-it: from 4.6.17 before 6.4.2 — fixed in 6.4.2
How to fix
Upgrade to a fixed version: grokability snipe-it 6.4.2. Check the vendor advisory for mitigations.
References
- https://advisory.checkmarx.net/?search=CVE-2024-5685
- https://devhub.checkmarx.com/cve-details/CVE-2024-5685/
- https://github.com/snipe/snipe-it/commit/34f1ea1c0ecd403047cd1327569ee391a7201cc1
- https://github.com/snipe/snipe-it/pull/14745
- https://github.com/snipe/snipe-it/releases/tag/v6.4.2
- https://advisory.checkmarx.net/?search=CVE-2024-5685
- https://devhub.checkmarx.com/cve-details/CVE-2024-5685/
- https://github.com/snipe/snipe-it/commit/34f1ea1c0ecd403047cd1327569ee391a7201cc1
- https://github.com/snipe/snipe-it/pull/14745
- https://github.com/snipe/snipe-it/releases/tag/v6.4.2
Get alerted when CVE-2024-5685 or the next vulnerability affects your stack