What’s Vulnerable › Vulnerabilities
CVE-2024-56915
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Netbox Community v4.1.7 and fixed in v.4.2.2 is vulnerable to Cross Site Scripting (XSS) via the RSS feed widget.
Affected products
- NetBox: from 4.1.7 before 4.2.2 — fixed in 4.2.2
How to fix
Upgrade to a fixed version: NetBox 4.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/netbox-community/netbox/releases/tag/v4.1.7
- https://github.com/noxlumens/Vulnerability-Research/tree/main/CVE-2024-56915
- https://youtu.be/n_5w0WVP8zE
Get alerted when CVE-2024-56915 or the next vulnerability affects your stack