What’s Vulnerable › Vulnerabilities
CVE-2024-57030
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Wegia < 3.2.0 is vulnerable to Cross Site Scripting (XSS) in /geral/documentos_funcionario.php via the id parameter.
Affected products
- LabRedesCefetRJ WeGIA: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: LabRedesCefetRJ WeGIA 3.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-57030 or the next vulnerability affects your stack