What’s Vulnerable › Vulnerabilities
CVE-2024-5709: WPBakery <= 7.7 - Authenticated (Author+) Local File Inclusion
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-06 · updated 2026-06-17
- Weakness: CWE-22
Description
The WPBakery Visual Composer plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 7.7 via the 'layout_name' parameter. This makes it possible for authenticated attackers, with Author-level access and above, and with post permissions granted by an Administrator, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.
Affected products
- WPBakery Page Builder: before 7.8 — fixed in 7.8
How to fix
Upgrade to a fixed version: WPBakery Page Builder 7.8. Check the vendor advisory for mitigations.
References
- https://wpbakery.com/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7fad30c8-fd8a-4cf2-a3aa-16a374231b87?source=cve
Get alerted when CVE-2024-5709 or the next vulnerability affects your stack