What’s Vulnerable › Vulnerabilities
CVE-2024-5713: if-so < 1.8.0.4 - Reflected XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The If-So Dynamic Content Personalization WordPress plugin before 1.8.0.4 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers
Affected products
- If-So Dynamic Content Personalization: before 1.8.0.4 — fixed in 1.8.0.4
How to fix
Upgrade to a fixed version: If-So Dynamic Content Personalization 1.8.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/eb3f24a7-3171-42c3-9016-e29da4f384fa/
- https://wpscan.com/vulnerability/eb3f24a7-3171-42c3-9016-e29da4f384fa/
Get alerted when CVE-2024-5713 or the next vulnerability affects your stack