What’s Vulnerable › Vulnerabilities
CVE-2024-57190
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-284
Description
Erxes <1.6.1 is vulnerable to Incorrect Access Control. An attacker can bypass authentication by providing a "User" HTTP header that contains any user, allowing them to talk to any GraphQL endpoint.
Affected products
- npm erxes: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: npm erxes 1.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/erxes/erxes/commit/4ed2ca797241d2ba0c9083feeadd9755c1310ce8
- https://www.sonarsource.com/blog/micro-services-major-headaches-detecting-vulnerabilities-in-erxes-microservices/
Get alerted when CVE-2024-57190 or the next vulnerability affects your stack