What’s Vulnerable › Vulnerabilities
CVE-2024-5720: Logsign Unified SecOps Platform Command Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Logsign Unified SecOps Platform Command Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Logsign Unified SecOps Platform. Although authentication is required to exploit this vulnerability, the existing authentication mechanism can be bypassed. The specific flaw exists within the implementation of the HTTP API. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-24168.
Affected products
- Logsign Unified SecOps Platform: from 6.4.6 before 6.4.8 — fixed in 6.4.8
How to fix
Upgrade to a fixed version: Logsign Unified SecOps Platform 6.4.8. Check the vendor advisory for mitigations.
References
- https://support.logsign.net/hc/en-us/articles/19316621924754-03-06-2024-Version-6-4-8-Release-Notes
- https://www.zerodayinitiative.com/advisories/ZDI-24-613/
Get alerted when CVE-2024-5720 or the next vulnerability affects your stack