What’s Vulnerable › Vulnerabilities
CVE-2024-5722: Logsign Unified SecOps Platform HTTP API Hard-coded Cryptographic Key Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-321
Description
Logsign Unified SecOps Platform HTTP API Hard-coded Cryptographic Key Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of Logsign Unified SecOps Platform. Authentication is not required to exploit this vulnerability. The specific flaw exists within the HTTP API. The issue results from using a hard-coded cryptographic key. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-24170.
Affected products
- Logsign Unified SecOps Platform: from 6.4.6 before 6.4.8 — fixed in 6.4.8
How to fix
Upgrade to a fixed version: Logsign Unified SecOps Platform 6.4.8. Check the vendor advisory for mitigations.
References
- https://support.logsign.net/hc/en-us/articles/19316621924754-03-06-2024-Version-6-4-8-Release-Notes
- https://www.zerodayinitiative.com/advisories/ZDI-24-614/
Get alerted when CVE-2024-5722 or the next vulnerability affects your stack