What’s Vulnerable › Vulnerabilities
CVE-2024-5730: Pagerank Tools <= 1.1.5 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The Pagerank tools WordPress plugin through 1.1.5 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- Pagerank tools: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: Pagerank tools 1.1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/17482b2c-c9ba-480a-8000-879baf835af7/
- https://wpscan.com/vulnerability/17482b2c-c9ba-480a-8000-879baf835af7/
Get alerted when CVE-2024-5730 or the next vulnerability affects your stack