What’s Vulnerable › Vulnerabilities
CVE-2024-5744: WP eMember < 10.6.7 - Reflected XSS
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The wp-eMember WordPress plugin before 10.6.7 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers
Affected products
- wp-eMember: before 10.6.7 — fixed in 10.6.7
How to fix
Upgrade to a fixed version: wp-eMember 10.6.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ba50e25c-7250-4025-a72f-74f8eb756246/
- https://wpscan.com/vulnerability/ba50e25c-7250-4025-a72f-74f8eb756246/
Get alerted when CVE-2024-5744 or the next vulnerability affects your stack