What’s Vulnerable › Vulnerabilities
CVE-2024-57440
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-121
Description
D-Link DSL-3788 revA1 1.01R1B036_EU_EN is vulnerable to Buffer Overflow via the COMM_MAKECustomMsg function of the webproc cgi
Affected products
- Dlink Dsl-3788 Firmware: before 1.01R1B037 — fixed in 1.01R1B037
How to fix
Upgrade to a fixed version: Dlink Dsl-3788 Firmware 1.01R1B037. Check the vendor advisory for mitigations.
References
- https://blog.sparrrgh.me/fuzzing/embedded/2025/01/26/fuzzing-embedded-systems-2.html
- https://supportannouncement.us.dlink.com/security/publication.aspx?name=SAP10418
- https://www.dlink.com/en/security-bulletin/
Get alerted when CVE-2024-57440 or the next vulnerability affects your stack