What’s Vulnerable › Vulnerabilities
CVE-2024-5757: Elementor Header & Footer Builder <= 1.6.35 - Authenticated (Contributor+) Stored Cross-Site Scripting via Site Title Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Elementor Header & Footer Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the url attribute within the plugin's Site Title widget in all versions up to, and including, 1.6.35 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Brainstorm Force, Nikhil Chavan Elementor – Header, Footer & Blocks Template: before 1.6.36 — fixed in 1.6.36
How to fix
Upgrade to a fixed version: Brainstorm Force, Nikhil Chavan Elementor – Header, Footer & Blocks Template 1.6.36. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/header-footer-elementor/tags/1.6.35/inc/widgets-manager/widgets/class-site-title.php#L461
- https://plugins.trac.wordpress.org/changeset/3101672/#file3
- https://wordpress.org/plugins/header-footer-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b5ab022c-c16c-488b-b004-a7351f8fa3d3?source=cve
- https://plugins.trac.wordpress.org/browser/header-footer-elementor/tags/1.6.35/inc/widgets-manager/widgets/class-site-title.php#L461
- https://plugins.trac.wordpress.org/changeset/3101672/#file3
- https://wordpress.org/plugins/header-footer-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b5ab022c-c16c-488b-b004-a7351f8fa3d3?source=cve
Get alerted when CVE-2024-5757 or the next vulnerability affects your stack